Okay
  Public Ticket #1845110
Stucked at "Uploading website"
Open

Comments

  • Maksymilian started the conversation

    Hi,

    when I try to sync my website via FTP (port 21) it gets stuck in "uploading website". When I press "cancel" the whole app crashes or closes. 

    Dunno why. It's just completly stucked. The log says actually nothing or am I watching the wrong log file?

  • Maksymilian replied

    Version: 0.32.4

    OS: Windows 10 (64-Bit)

    Test connection: success

  • Maksymilian replied

    When the upload folder is empty, the uploading is working somehow.

  • Maksymilian replied

    When I delete "files.publii.json", the upload is working.

  • snrkl replied

    I am seeing the exact same with with SSH (password) based upload on OSX Version 0.32.4 (0.32.4)

    My target directory is empty and it still won't work. 

    Test connection works fine...

  • Maksymilian replied

    @snrkl have u tried open the application as administrator?

  • snrkl replied


    Maksymilian replied 

    @snrkl have u tried open the application as administrator?

    That's not a thing on Mac OSX...

  •  316
    Thomas replied

    Hi Maksymilian,

    Could you provide a backup of your website and access data to your server in a private reply? It is the only way how I can debug your issue and find a potential problem.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

  •   Maksymilian replied privately
  •   Thomas replied privately
  •   Maksymilian replied privately
  •   Thomas replied privately
  •   Maksymilian replied privately
  •   Thomas replied privately
  • snrkl replied

    For what it is worth, I managed to solve my SFTP issue.

    It turned out to be a permissions problem with the destination content directory.

    Working properly for me now, but it would be useful if publii could report an error and not crash when it doesn't have permission to write to the target directory. Also the "test connection" button could do a write / erase test of a temp file to check it has permissions when testing the connection.

  •  316
    Thomas replied

    Hi Maksymilian and snrkl,

    @Maksymilian - your issue is most probably related to wrong permissions to the /web/ directory. When I set the remote path to /public_html/web/ or /public_html/test/ Publii were able to create these catalogs and content in it (owner of catalog is set to your FTP user, when owner of the /web/ catalog is set to the same user as group).

    @snrkl - thank you for your feedback. I will address your issue and also case of Maksymilian to create a functionality which will return an error when there is an permission denied problem during FTP/SFTP connection.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

  •  316

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

  • Marcelo replied

    I started getting the same error today on Windows 10. If i cancel sync, Publii crashes...

  • Maksymilian replied

    Hi Thomas,

    just followed your instructions. Works perfectly! Dziękuję! and goodbye!